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 WORKSHOP DESCRIPTION 

Overview 
Want to learn how to create your own Web pages or brush up on your Web editing skills? 
Creating Web pages and managing your Web site with Dreamweaver is easier than you might 
think. This workshop introduces you to the Dreamweaver environment and its basic Web 
editing tools. Topics include: creating a new Web document, defining a site, adding new content 
and importing existing text from Microsoft® Word, formatting text and inserting images. 
 

Prerequisites 
Individuals taking this workshop should also have basic computer skills, knowledge of  the Web, 
basic Web browser skills, and the ability to effectively work in the Windows or Macintosh OS 
environment. 

Objectives 
Participants attending this workshop will: 

▪ Attain a beginning understanding of  the Dreamweaver environment. 
▪ Use Dreamweaver to: 
▫ Create a new Web document. 
▫ Define a Site. 
▫ Add new content from a Microsoft Word document. 
▫ Format and style text. 
▫ Insert images. 

 
 

INTRODUCTION TO DREAMWEAVER 
 
Adobe Dreamweaver CS4 is a full-featured Web design suite that allows you to create and edit 
HTML and XHTML documents (Web pages).  With Dreamweaver, as with other HTML and 
XHTML editors, knowledge of  the XHTML mark-up language is not required to create 
professional-grade websites. 
 
Unlike many Web editors, Dreamweaver is a paletted environment.  This means that the user 
interface is a series of  windows or palettes, called panels, which can be moved around the screen 
by the user.  If  you have used Adobe Photoshop then you have already been introduced to a 
paletted environment. 
 
The remainder of  this document will use screen samples from the Windows-based version of  
Dreamweaver CS4. 
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Sample Dreamweaver Interface 

 
 Legend 

1 Objects (Insert) Panel – Allows you to add images, tables, and multimedia to your Web 
pages.  Available from the Window menu. 

2 Toolbar – Shortcuts for Document window commands, text field for page title. 

3 Document Window – Provides a work area to insert and arrange text, images, and 
other elements of  your Web page. 

4 Properties Panel – Allows you to view and modify properties of  an object that is 
selected in the Document window. 

5 History Panel – Tracks commands you perform and allows you to return your page to a 
previous state by backtracking through those commands. 

6 Files Panel – Lists the various folders and files associated with the site. 

4 
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Document Window 
The Document window contains the toolbar, document title, file name, Code View window to 
view the HTML and XHTML code, and the WYSIWYG window to view your Web page 
graphically (Design View). 
 

 

Toolbar 
The toolbar is actually part of  the Document window and allows you to toggle between the 
Code View and Design View windows (View Modes), set your page title, preview your page in a 
browser, select different view options and check your document for browser-specific errors. 
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Insert Panel 
The Insert panel contains various icons that allow you to easily insert different types of  elements 
into your Web documents.  For example, insert a table, picture or horizontal rule. 
 

 
or 

 

Properties Panel 
Using this panel you can modify the properties of  an element selected in the Document window. 
 

Text Properties 

 
 

Text Properties with CSS Attributes 

 
 

Image Properties 

 
 

HR Tag Properties 
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History Panel 
This panel makes it easy to undo multiple actions at the same time.  To undo a series of  actions 
place your cursor in the Design view document, then within the History panel click and drag the 
undo slider to the desired position. 
 
To activate the History panel: go to Window > History or press Shift+F10. 
 

 
 

Where to find Help in Dreamweaver 
There are a variety of  ways to find help in Dreamweaver.  Below are just a few of  them. 

1. Click the Help menu and select Dreamweaver Help.  This opens a browser to the Adobe 
Dreamweaver Help and Support site. 
 

2. From the Properties panel click the question mark button ( ).  This opens the Help site 
mentioned above and displays information about each area of the Properties panel. 
 

3. Click the Help menu and select Reference.  The Results panel opens to the Reference tab.  
Here you can select a Book and then get more detailed information from pages of that book. 
 
This is a great way to learn more about HTML and XHTML from the O'Reilly HTML 
Reference book. 
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Create a New File 
Most Web pages you create will be simple HTML pages.  The steps below show you how to 
create a new HTML document. 
 

step 1. Click the File menu and select New.  The New document window appears. 

 
 

step 2. From the New Document window select the Blank Page tab, then the HTML 
selection from Page Type. 

step 3. Optionally, you may select a specific layout for your new Web page other than the 
default of  none, which is an empty page. 

step 4. Click the Create button to create and open your new document in the Document 
window. 

Open an Existing File 
step 1. Click the File menu and select Open. 
step 2. From the Open window select the file you want to open (click the file name) and 

click the Open button.  Dreamweaver will now open your document in the 
Document window. 

 

Create a New File from an Existing File 
step 1. Open your existing file using the steps above. 
step 2. Click the File menu and choose Save As.  Give your file a new name.  Be sure the 

file ends with either “.htm” or “.html” (do not include the quotes). 
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SETTING UP A DREAMWEAVER SITE 
 
Before creating or editing your Web pages, Dreamweaver can help you manage your HTML files 
by defining a site.  A site is a collection of  documents, images and Web pages in a single folder.  
Dreamweaver can point to the files on your hard disk where these site files are located. 
 

 

 

TIP:  Keeping everything within a master folder enables you to easily transfer 
files to a Web server without changing the organization of  the files and sub-
folders.  If  you do not organize your site files on the Web server the same as they 
are organized on your local computer, hyperlinks will not work and images will 
not display properly. 

 

How to create a site 
step 1. To set up a local site, first select the New Site option from the Site menu. 
step 2. When the Site Definition dialog box appears click the Advanced tab. 

 

 
 

step 3. Enter a name for your site in the Site name field. 
step 4. Click the folder icon at the end of  Local root folder field to locate a local folder to 

serve as the master folder for all of  your files for this site. 
step 5. Click the folder icon at the end of  Default images folder field to locate a local 

folder that contains all of  your image files for this site. 
step 6. Click OK to create your new site. 

 
Once you have defined your Dreamweaver site it is visible in the Files panel.  Here 
you can simply double-click any file listed to open and edit it.  You can also move 
and/or rename a file without incurring any broken links. 
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FORMATTING AND VIEWING A DOCUMENT 

Page Properties 
You can access the Page Properties dialog box from the Modify menu or from the Properties 
panel (as long as you have not selected an image).  The Page Properties dialog box allows you 
to define a background, text, and link colors, as well as a page title, among other items. 
 
The list of  categories in the Page Properties window depends upon whether or not you are 
using Cascading Style Sheets (CSS).  Below is the main Page Properties window showing the 
Appearance (CSS) tab. 
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Saving Your Document 
To save your document, choose the Save or Save As option under the File menu. 
 
After you save your document it will appear 
in the Files panel as a file.   

 

If  your Files panel is not visible, you can 
activate it from Window > Files, or by 
pressing <F8>. 

 

 

Previewing in a Browser 
You can preview your pages in a Web browser by either selecting File > Preview in Browser or 

by clicking the preview button  on the Document Window Toolbar.  In addition, you can 
add to the list any browser installed on your computer – e.g. Firefox – by using the Edit 
Browser List option. 
 

 
 
 

 
 

 

 
EXERCISE 1 Modifying Page Properties 

1. If  you have not already done so, create a site that points to the dw-intro folder. 

2. From the dw-intro site, open the file sacstate.htm in Dreamweaver. 

3. Add a page title and background color to your document. 

4. Save your changes to the sacstate.htm file. 

5. Preview your updated document in Microsoft Internet Explorer or Firefox. 
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FORMATTING AND STYLING TEXT 
 
Virtually all of  the text formatting and styling you wish to apply to your document can be done 
within the Design view in conjunction with the fields and buttons on the Properties panel. 
 

 

Figure 1 - HTML portion of  the Properties panel 

 

 

Figure 2 - CSS portion of  the Properties panel 

Creating Paragraphs 
To create a new paragraph in Dreamweaver, place your cursor in the Design view document 
and press the Enter key (PC) or Return key (Macintosh).  This will create a new pair of  
paragraph tags with a blank space, represented as <p>&nbsp;</p>.  Since there is no easy 
way to indent the first line of  a paragraph on a Web page, individual paragraphs are separated by 
a double space. 

Creating Line Breaks 
Line breaks <br /> are created by holding down the SHIFT key and pressing Enter or 
Return. 

Creating Headings 
To create a heading, click and drag the mouse pointer over the text to select it, and then use the 
Format drop-down menu on HTML portion of  the Properties panel to select the desired 
heading value, such as heading 1. 
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Changing text format 
Selecting a font face, size, color and paragraph alignment for your text can be done using the 
CSS portion of  the Properties panel (second image above). 

 
step 1. Click and drag the mouse pointer over the text to highlight it. 

step 2. Click the CSS button  on the Properties panel. 
step 3. Select a property to change, such as the Font from the drop-down menu.  The first 

time you select a property on the CSS screen the New CSS Rule window appears.  
This window allows you to create a new rule (style) – a group of  properties – that 
can be applied to different selections on your webpage, or only to the text you just 
selected. 
 

 
 

step 4. From the Selector Type drop-down menu be sure that Class is chosen. 
step 5. Type a name for your selector (style) in the box beneath Selector Name.  Do not 

uses spaces or any special characters, only lowercase letters and numbers.  You can 
use a dash between words, such as text-green, to make it more readable. 

step 6. Under Rule Definition, select (This document only) to create a new CSS rule 
within this webpage.  If  you have many webpages and want to share a group of  
styles between them, you can select (New style sheet file).  This option creates an 
external CSS file that can be linked to each of  your webpages so they share a 
common list of  styles. 
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step 7. Click OK.  The CSS Rule definition window appears.  Here you can edit the 
properties of  your new style to apply to the text you selected in step 1 above. 
 

 
 

step 8. When you complete your changes, click OK.  The window closes and displays your 
highlighted text in the Design View area with your style applied to it.  The name of  
your rule appears in the Targeted Rule drop-down list while the text is selected. 
 

 
 

step 9. To further change the way your new style appears, click inside the text area 
associated with the rule (or highlight it), then click the Edit Rule button in the CSS 
portion of  the Properties panel. 

step 10. In the CSS Rule definition window for your selected style, make the necessary 
changes to the properties. 

step 11. When you complete your changes, click OK. 
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Apply an Existing Style to Text 
 

step 1. Click and drag the mouse pointer over the text you want to modify. 
step 2. You now have two ways to choose an existing style to apply to your highlighted text: 

a. From the HTML area of  the Properties panel, select an option from the drop-
down arrow next to Class.  This area lists only styles that are also classes – rules 
that start with a period.  

b. From the CSS area of  the Properties panel, select a rule from the Targeted 
Rule drop-down list.  That style (rule) is now applied to your selected text. 

step 3. If  you want to create a new style (rule), from the CSS area of  the Properties panel 
select <New CSS Rule> from the list, and then click Edit Rule. 

 
 

 

 

 
EXERCISE 2 Formatting Text 

1. Open your updated file, sacstate.htm, if  it is not already opened in 
Dreamweaver. 

2. Format the text to make it appear similar to the Web page sacstate_ex2.htm, 
including: 

a. Inserting new paragraphs after the section titles ‘Faculty Resources’ and 
‘Library Instruction.’ 

b. Adding headings to ‘Faculty Resources’ and ‘Library Instruction,’ and 
create a new style (rule) with custom properties of  your choosing. 

c. Changing font face, size, color and bold or italics of  some of  the text – 
create new styles (rules) for each set of  properties. 

d. Center the university address at the bottom of  the page, change its color 
and insert line breaks between each section of  the address (see 
sacstate_ex2.htm). 

3. Save your changes. 

4. Preview your updated document in a Web browser. 
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ADDING CONTENT FROM A MICROSOFT WORD DOCUMENT 
 
You can easily copy and paste content from a Microsoft Word document (or other word 
processor) directly into your Dreamweaver document.  This can save you valuable time, 
especially if  you have a lengthy document.  Unfortunately, you may lose some of  your 
formatting during this process. 
 

How to copy and paste content from a word processor 
step 1. Open your document using your word processor, such as Microsoft Word. 
step 2. Select your text using the cursor and/or mouse. 
step 3. Copy your text: In Windows press CTRL+C or press Command+C on the 

Macintosh. 
step 4. Open your HTML or XHTML document in Dreamweaver then place the cursor in 

the document where you want to paste your content. 
step 5. Paste your content into your Dreamweaver document using either Edit > Paste or 

Edit > Paste Special. 
step 6. Format the text in your Dreamweaver document as you would like it to appear on 

your Web page.  Some of  the formatting from the word processor may have been 
lost. 

 

INDENTING PARAGRAPHS AND CREATING LISTS 
 

Indenting a Paragraph 
You can use the increase/decrease indent buttons on the Properties panel to insert or remove 
blockquote tags.  The blockquote tag, <blockquote>, will indent a given paragraph from 
both the left and right margins, thereby creating a visual separation similar to those used in 
research papers when more than two lines from a source are being cited. 
 
 
 

 
 
 

Blockquote buttons 
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Creating Lists 
You can add a new list by choosing Insert > HTML > Text Objects and then selecting the 
desired option, Unordered List, Ordered List or List Item.  You can also change existing text 
using the Properties panel to create unordered <ul> and ordered <ol> lists. 
 
 
 

 
 
You can modify an existing list by clicking within any item in the list, then clicking the List Item 
button  on the Properties panel.  In the List Properties window you can customize 
the appearance of  your bullets or the numbering of  each list item. 
 

 
 

 

 
EXERCISE 3 More Text Formatting 

1. Open your updated file, sacstate.htm, in Dreamweaver. 

2. Format the text to make it appear similar to the Web page sacstate_ex3.htm: 

a. Indenting the Faculty Resources paragraph. 

b. Creating a multi-level list from the Library Instruction content. 

3. Copy and paste the text from the Microsoft Word document ctl.doc (in the 
docs folder) into sacstate.htm just before the university address. 

4. Format the text for The Center for Teaching and Learning, including a 
bulleted list of  the topics (see sacstate_ex3.htm). 

5. Save your changes. 

6. Preview your updated document in a Web browser. 

 
 

Unordered and ordered list buttons 
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WORKING WITH IMAGES 
It is important that you prepare your images before inserting them into your Web pages.  Use a 
graphics editor, like Adobe Photoshop Elements to optimize and resize your images for use 
on the Web.  Save your files as either GIF or JPG files in the images folder within the site folder. 

Using a Background Image 
You can select a background image for your Web document by accessing the Page Properties 
option from the Modify menu or from the Properties panel. 
 

 

Inserting an Image 
You can insert an image by clicking the insert image button ( ) on the Common tab of  the 
Objects (Insert) panel.  Then select the Image option to insert your image. 
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After inserting an image you can set the image alignment, spacing and hyperlink attributes from 
within the Properties panel. 
 
 
 
 
 

 
 
 
 
 
 

Adding a Horizontal Rule 
You can add a horizontal rule from the Insert menu by selecting HTML > Horizontal Rule 

or click the Insert Horizontal Rule icon from the Insert Panel ( ).  To modify the <hr /> 
properties, click the horizontal rule in the Design view.  You can then modify the attributes from 
within the Properties panel. 
 
 

 

 

 
EXERCISE 4 Images and Horizontal Rules 

1. Open your updated file, sacstate.htm, if  it is not already opened in 
Dreamweaver. 

2. Insert the image library_poppies.jpg after the Library Instruction heading.  Be 
sure to align the image to the right. 

3. Insert the image libraryquad_new.jpg at the beginning of  the paragraph for 
The Center for Teaching and Learning section.  Resize the image to make it 
smaller than the original. 

4. Add a horizontal rule just before each major heading in your document. 

5. Save your work and preview your changes in a Web browser. 

6. Compare your Web page with the file sacstate_final.htm 

 
 

Width and height in pixels 
 
 
 

Alternate text 
 
 
 

Image alignment 
 
 
 

Vertical and horizontal space around the image 
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RESOURCES  

Faculty / Staff Resource Center  
Located in ARC 3012. Assistance available on walk-in basis. 
FSRC Website - http://www.csus.edu/irt/acr/fsrc/ 

Training & Tools eNewsletter 
To receive email notification regarding online seminars, new technology/tools, and other online 
teaching, technology and learning events, fill out and submit the Training & Tools eNewsletter 
request form - http://www.csus.edu/atcs/tools/newsletter/request-form-ait-news.stm. 

Getting Help 
 University Help Desk 
  (916) 278-7337 or helpdesk@csus.edu  
 Academic Technology Consultants 
  http://www.csus.edu/atcs/contact.htm 
  1on1 Help @ ATCS on Thursdays 1-4 pm in ARC 3005 (no appointment necessary) 
 Help Desk - Problem Reports & Contact Information 
  http://www.csus.edu/irt/helpdesk/contact.stm 
 Training Requests 
  training@csus.edu 

Campus Resources 
 Training 
  http://www.csus.edu/training 
 Training Handouts 
  http://www.csus.edu/training/handouts 
 Online Tutorials 
  http://www.csus.edu/atcs/tools/training/tutorials.stm 
 Educational Tools 
  http://www.csus.edu/atcs/tools 
 Accessibility at Sacramento State 
  http://www.csus.edu/accessibility  

Books on Dreamweaver and HTML 
 Dreamweaver CS4 Bible by Joseph W. Lowery 
 Adobe Dreamweaver CS4 Hands-On Training by Garrick Chow 
 Dreamweaver CS4 for Dummies by Janine C. Warner 
  HTML, XHTML, and CSS: 6th Edition by Elizabeth Castro 
  http://www.cookwood.com/html/extras/cssref.html 
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